Re: Newbie Question2 ...v1.1 vs v1.2 M2

From: Andrus Adamchik (
Date: Fri Feb 11 2005 - 14:47:15 EST

  • Next message: Gentry, Michael \(Contractor\): "RE: NEWBIE: cayenne.xml"

    > Should I use version 1.1 or go straight for 1.2M2?
    > Are the new features of 1.2 documented?
    > Also is it ok to run Cayenne with jdk1.5 and Tomcat 5.5?
    > Thanks!
    > /Fredrik

    Hi Fredrik,

    1.2 is still in the early stages, so to avoid "surprises" with sudden API
    changes for the new features, I'd recommend 1.1, especially if you are
    still learning Cayenne.

    Having said that, 1.2 is a requirement if you have an existing database
    with PK generation configured using "auto-increment" or "identity"
    columns, and you want to preserve that.

    For the latest status of the new features check out User Guide bundled
    with a given release. Chapter "Guide to 1.2 Features" under


    This archive was generated by hypermail 2.0.0 : Fri Feb 11 2005 - 14:47:18 EST