On Thursday, March 27, 2003, at 08:23 PM, Andrus Adamchik wrote:
>
>> One plea..would it be possible to use regular names like
>> 'ProcedureParameter', 'addCallParameter' etc.? I find these
>> abbreviated
>> names very hard to remember, especially since we don't call Attribute
>> 'Attr' either..I think we can afford the additional characters ;)
>
> +1.
>
> I will do the renaming. Actually I was going to do that earlier, but I
> wanted to stay consistent with "addParam" methods in parameterized
> queries. I guess I will rename those as well.
Finally Cayenne started to work with Oracle Stored Procedures (PL/SQL
procedures and functions to be precise). I did all the API renaming
across the board (as discussed: *Param -> *Parameter). One thing you
may notice that Expression.expWithParams became "expWithParameters",
not "expressionWithParameters". In case of expressions we use "exp"
abbreviation consistently in many methods, and I would like to keep it
this way for one reason - this is the case where shortest method name
is the best due to the possible chaining, e.g.:
Expression e = e1.orExp(e2).andExp(e3).andExp(e4);
Also Procedure/ProcedureParameter no longer inherit from
DbEntity/DbAttribute. This was dubious at best (Stored Procedure having
a primary key :-)). Though in the future ResultSets returned by the
procedure may need to be better described in terms of mapping (now
Cayenne guesses all the metadata information used to read result sets).
Hopefully procedures will make its way to the DataMap and MapLoader
before beta (but not the modeler).
Andrus
This archive was generated by hypermail 2.0.0 : Sat Mar 29 2003 - 02:32:28 EST