Hi Andrus,
On Dec 10, 2004, at 2:04 PM, Andrus Adamchik wrote:
> I agree, switching XMLEncoder to JDOM is a good thing (going from
> "object
> -> XML stream" behavior to "object -> JDOM tree -> XML stream". So I'd
> say
> just keep the old API (we can deprecate it later, once cayenne.map
> package
> is switched to JDOM for encoding), and add a "root" and "current" JDOM
> Element properties (and corresponding getter/setter methods), and maybe
> also "printTo(PrintWriter)".
>
This all sounds good (including the stuff I snipped out), although I
might change names of a few things.
> XMLSerializable:
>
> XMLSerializable should not include JDOM classes in the method
> signature,
> but the implementation can retrieve Elements from the XMLEncoder
> internally.
XMLSerializable will be staying as it is. I see no need to change it,
since everything will be done in XMLEncoder.
> DataObject and XMLSerializable:
>
> I agree with your suggestion. So how about CayenneDataObject class will
> implement XMLSerializable, but DataObject interface will not.
>
> Does it make sense?
This sounds good. Then if people don't want to support it they don't
need to. Likewise, people using CayenneDataObject will gain the
functionality for free. I like it :-)
-- Kevin
This archive was generated by hypermail 2.0.0 : Fri Dec 10 2004 - 14:51:44 EST