Ahh, I hadn't even noticed the domain. Cool.
I generally like the idea. Although, it would be nicer to have a bit more
control. E.g., discard nulls or group them all together at the end.
As a suggested code cleanup, the following:
e.getCause() != null && e.getCause()
instanceof org.apache.cayenne.ObjPathResolvingException
Could be simplified to just the instanceof operation (it's null safe and
returns false if the argument is null).
-- KevinOn 11/7/07 5:28 PM, "Aristedes Maniatis" <ar..aniatis.org> wrote:
> > On 08/11/2007, at 9:22 AM, Kevin Menard wrote: > >> Please submit the patch through JIRA. By submitting through JIRA >> you can >> click a button that grants the ASF a non-exclusive license to use >> the code. >> This is a prerequisite for the code to get committed. > > > I'll take care of all that with Marcin and get him to sign a CLA. We > should be expecting more contributions from Marcin in the future. > > I'll also work with him to clean up the code, the naming and comment > it a bit, but what do you think of the concept? An extra switch in > Ordering which allows us to ignore paths that don't full resolve? Is > there a better way? > > Ari
This archive was generated by hypermail 2.0.0 : Wed Nov 07 2007 - 17:44:47 EST